× Technical Discussions

Drives Slipping Anyone have any ideas ?

  • David
  • David's Avatar Topic Author
  • Offline
  • Admiral - Administrator
More
5 years 4 months ago #1614 by David
David created the topic: Drives Slipping Anyone have any ideas ?
I have two 1989 cobra engines and drives. When driving above 1500-2000 RPM I can hear the engine rev louder the sync guage shoots up on the port side but the RPMs remain constant and the boat pull to port. I have changed the props no effect. Checked to ensure someone did not mix the drives The seem correct. Any ideas ?

David
1990 Sunray Infinity
Twin 5.7 Cobra's

Please Log in or Create an account to join the conversation.

More
5 years 4 months ago #1616 by jamie mac
jamie mac replied the topic: Re: Drives Slipping Anyone have any ideas ?
HAS IT BEEN THIS WAY SINCE YOU PUT IT IN THIS YEAR OR DID IT JUST START?? IT SOUNDS LIKE A SPUN PROP HUB , BUT YOU SAY YOU CHANGED THEM. THE PORT SIDE REVS UP AND IT PULLS TO PORT SOUNDS LIKE A SPUN PROP. SORRY DAVE I CANT GET PAST SPUN PROP. GOOD LUCK.

2006 mainship rumrunner

Please Log in or Create an account to join the conversation.

  • David
  • David's Avatar Topic Author
  • Offline
  • Admiral - Administrator
More
5 years 4 months ago #1621 by David
David replied the topic: Re: Drives Slipping Anyone have any ideas ?
It has been that way since I bought the boat :pinch: I changed the props last year and it still did the same thing. I thought then it was like cavatation and it was hitting an air pocket caused by a broken exhaust hose. Changed that this year and still the same issue.
When I am crusing at 3000 RPM the best I can get out of her is around 19 mph

David
1990 Sunray Infinity
Twin 5.7 Cobra's

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Moderators: kingstonal
Time to create page: 0.314 seconds
Powered by Kunena Forum